News:

Precision Simulator update 10.175 (29 May 2024) is now available.
Navburo update 13 (23 November 2022) is now available.
NG FMC and More is released.

Main Menu

PSX.NET.MSFS.WASM - Smooth PSX to MSFS Scenery Link

Started by Gary Oliver, Sun, 18 Sep 2022 22:49

Gary Oliver

Hans,

Having disabled the cinematic mode in accessibility I have found that it can break ground altitude injections - so you fly through the ground.

Did you ever work out any more details about what causes the behavior?

Banging my head against a brick wall here...

Cheers
G
Quote from: B747-400 on Thu,  6 Oct 2022 15:44Hi,

It seems, as it depends on the location where to start. If I try to start from LOWW WASM model sets me outside the cockpit. Trying exactly the same from LZIB I'm in the cockpit.

First I set PSX to airport RWY (lets say LOWW / 29) then start MSFS and setup a flight from LOWW / 29 as well.

Perhaps one of you guys can try this to validate if it's WASM or my setup.

THX & cheers
Hans

Gary Oliver

#141
I can reliability work around it by clicking somewhere on the map > Set as Departure > Fly Now

PS: New WASM module for reliability fixes

B747-400

Gary,

main issue here, was the order in which I start the programs (posting #65)

Switching off the accessibility did not have huge impact on my experience, except circling around the acft. But tbh: I did not do plenty of flights in the meantime, so hard do tell.

I'll download latest WASM and test flight with my son in the afternoon. Perhaps I've new conclusions in the evening hrs.

Cheers
Hans

Aleks


macroflight

Since yesterday VatSpy (and map.vatsim.net) shows me with ground speed zero (or near zero, I've seen 0-10 knots).

Router 1.2
Client 1.99
Latest WASM from this thread (SHA1 hash of d18be5c6cd8ecf4c68ef26359a41ff3044821f11)
MSFS SU10
vPilot 3.4.7 (tried with and without PSX.NET.vPilot plugin and with and without the -rvztx 1 option)

Has anyone else seen this?

Aleks

Quote from: macroflight on Tue,  1 Nov 2022 18:20Since yesterday VatSpy (and map.vatsim.net) shows me with ground speed zero (or near zero, I've seen 0-10 knots).

Router 1.2
Client 1.99
Latest WASM from this thread (SHA1 hash of d18be5c6cd8ecf4c68ef26359a41ff3044821f11)
MSFS SU10
vPilot 3.4.7 (tried with and without PSX.NET.vPilot plugin and with and without the -rvztx 1 option)

Has anyone else seen this?


Saw the same, but refreshing the browser (map.vatsim.net) it updated to correct GS. SU11 with latest beta update.

B747-400

Gary,

updated to latest WASM and router / bridge.
First I recognized, I have to click "Ready to fly" again.

Flight was uneventful, but landing did not worked well.

I had no 50, 40, 30 ... callouts. Then, instead of touchdown, my plane submerged below ground. But not only the visual, PSX as well. No crashing ... but I had to stop anyway.

I documented with some screenshots and a saved .situ file as well.

Same happened with another flight. After switching to another flight model and bridge, it worked.

Here's the docu zip-file: docu

Cheers
Hans

Gary Oliver

Hans,

Do you have cinematic disabled in accessibility mode?  This is a symptom of the workaround I had to make.

Cheers
G


Quote from: B747-400 on Tue,  1 Nov 2022 19:50Gary,

updated to latest WASM and router / bridge.
First I recognized, I have to click "Ready to fly" again.

Flight was uneventful, but landing did not worked well.

I had no 50, 40, 30 ... callouts. Then, instead of touchdown, my plane submerged below ground. But not only the visual, PSX as well. No crashing ... but I had to stop anyway.

I documented with some screenshots and a saved .situ file as well.

Same happened with another flight. After switching to another flight model and bridge, it worked.

Here's the docu zip-file: docu

Cheers
Hans

macroflight

Quote from: Aleks on Tue,  1 Nov 2022 19:07Saw the same, but refreshing the browser (map.vatsim.net) it updated to correct GS. SU11 with latest beta update.

For me it's actually the opposite. I just realized that if I connect to VATSIM WHILE MSFS is loading (with PSX at 5000ft and 300 kts GS) and then reload VatSpy, I can actually see my flight with the correct ground speed for a short while, but as soon as MSFS has finished loading, VATSIM ground speed drops to zero.

macroflight

Quote from: B747-400 on Tue,  1 Nov 2022 19:50Here's the docu zip-file: docu

I did my best to fall through the world using your situ, but no luck.

When I load the situ, the plane is at the end of rw 26 at 130 knots, more or less on the runway but with the main gears sunk a foot or two into the tarmac.

When I enable motion, the plane bounces around a bit, but settles down on the ground and proceeds across the landscape at 130 knots. It goes up and down the hills, until it finally becomes airborne again, flies for a bit and then crashes with FATAL DAMAGE. But it never falls through the ground.

I tried the same thing with both the default scenery and https://flightsim.to/file/38358/loxz-fliegerhorst-hinterstoisser-zeltweg-austria (in case that one had any big holes in it).

I then reloaded the situ, and after the initial bounce pulled the aircraft into the air again, made a circuit and landed on rw26. I got the expected callouts, and landed normally without falling through the world.

(SU10 without any addons except the flightsim.to scenery for LOXZ)

Aleks

Just did flight on Vatsim and controller commented that my speed was junping from 0-1kt to actual.

B747-400

Gary,

"Skip Pre-Flight Cinematics" are "ON".

Cheers
Hans

Quote from: Gary Oliver on Tue,  1 Nov 2022 19:55Do you have cinematic disabled in accessibility mode?  This is a symptom of the workaround I had to make.

B747-400

Hi,

thx for checking out. Indeed, I'm running a scenery in LOXZ, as I do on all of the other airports I'm flying from/to as well.

As I needed some seconds to save the .situ file, I advanced to the end of rwy - but no chance for me to see  :(

Btw., same happens in LOWI thereafter. Also, I could not reposition the acft to EDDM ... down under as well.

Running SU10 here as well. Really strange ...

Cheers
Hans

Quote from: macroflight on Tue,  1 Nov 2022 21:00I did my best to fall through the world using your situ, but no luck.

Gary Oliver

This is definitely the same issue I had... can we chat on discord after WF to confirm...

However try clicking somewhere on the map and starting your flight "airborne 200ft" in MSFS and the problem will go away.

Cheers
G

B747-400

Of course!
I hope all goes fine with WF!
Cheers
Hans

macroflight

Quote from: Aleks on Tue,  1 Nov 2022 21:18Just did flight on Vatsim and controller commented that my speed was junping from 0-1kt to actual.

Here are some screenshots that show how the internal MSFS ground speed matches the PSX one (in this case 440 kts) while MSFS is loading, but drops to zero once loading is complete.

The internal MSFS ground speed seems to always match the ground speed that I can see in VATSIM.





I have tried to vary everything I could think of that might affect this: MSFS frame rate and vsync, PSX FPS, the order in which I start things, ... still no groundspeed except for those few seconds while MSFS is loading.

macroflight

I managed to get by groundspeed back by using duct tape (Python) and brute force... Hopefully this is good enough for Worldflight.

By taking the true groundspeed from PSX(*), and then injecting it into MSFS(**) at a very high rate(***), the MSFS ground speed is correct most if the time, and vPilot will then pickup the correct ground speed most of the time, which is probably good enough.

(*) using Hoppie's Python module
(**) using the SimConnect PyPi module
(***) since PSX.NET.MSFS sets it back to zero

Gary Oliver

Okay we will add that the the client today then.

Cheers
G

GodAtum

Going to try Gary's excellent work today. What are the startup steps, there seems to be a lot of different ways mentioned?

Prereqs: MSFS > General Options > Accessibility > Skip Pre Flight Cinematics = Yes

1/ Start PSX.MSFS client
2/ Start MSFS, select the PSX plane model and dep airport, and go.
3/ Start PSX.MSFS server
4/ Run PSX.NET.GateFinder to choose a position.

Gary Oliver

Godatum,

Latest instructions... DO NOT set Skip Cinematics... bad things happen with radalt... Instead when you start a flight in MSFS click the map and select departure so it spawns slightly in the air.

Basically start it all in any order, its all reliable now.