Welcome, Guest. Please login or register.
Did you miss your activation email?

News:
Precision Simulator update 10.129 (11 November 2020) is now available.
Aerowinx NG FMC and More is now released.

Author Topic: PSX.NET P3D ExternalSim is not working  (Read 606 times)

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
PSX.NET P3D ExternalSim is not working
« on: Thu, 29 Oct 2020 03:12 »
I posted this a week ago as a reply to another post in another topic but it attracted no response so I am hoping that with its own dedicated topic it will be seen and replied to.

I am having big problems getting PSX.NET P3D ExternalSim to work. I have been trying for almost three full days now and it is still not working.

I am operating on one computer running W7 64 bit Pro with P3Dv4.5 and have installed PSX.NET P3D4 on the same machine as directed by the installation manual.

I had something working very briefly at the start but the P3D aircraft appeared to have only the starboard main gear deployed whilst on the ground, all others were retracted. In the air only the left side gear would retract.

I have uninstalled PSX.NET numerous times and tried in vain to reinstalled it to my prefered "Program Files" folder but it appears that it is not possible to install anywhere other than the "Program Files (86)" folder irrespective of the choices that I have made. I wonder why I am given the option to choose when the installer will not allow me to.

I initially tried using my iFly aircraft in P3D and it took me a long time to realise that adjustments were being made to the aircraft config file. Once I realised this I decided to make a seperate folder in simobjects which I called iFly PSX and put just one aircraft texture folder and its single entry in the aircraft config file but that did not solve the problems.

I have also tried using a POSKYv4 aircraft but I get exactly the same results.

The Router box is suggesting that PSX is not connected to P3D but it did show a connection  on just one brief occassion. I have not been able to establish a connection since. I have tried switching Windows Firewall off but, again, to no avail. I have also listed the PSX.NET folder in the 'exclude files and locations' list in Microsoft Security Essentials.

I would like to cut and paste the router data and display it here but I am not able to copy it nor am I able to find a log file.

Is somebody able to help me with this? If so please use layman's terminology as a lot of the technical stuff that has been posted has gone over my head.

Thanks

Mike

garys

  • Join date: Nov 2012
  • Posts: 92
Re: PSX.NET P3D ExternalSim is not working
« Reply #1 on: Thu, 29 Oct 2020 05:28 »
Page 15 of the external.sim thread that you first posted in has 2 downloads available from Gary and Mark. The first is a firewall utility and the 2nd is an aircraft specifically configured for use with External.sim

Also make sure you run PSX as a boost server with the correct addresses as per the manual.

Give these a try and see if it helps

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #2 on: Thu, 29 Oct 2020 08:32 »
Thanks very much for your reply Garys.
I have done as you have suggested but to no avail I'm afraid. I notice however, that PSX does actually see the server and is connected to it. If I disconnect and re-run the router it connects again but the router box does not show a client.
I have taken a sreenshot of the router box display but I cannot see how to attach it or show it here.

ExternalSim XML
<?xml version="1.0"?>
<Settings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <SettingsVersion>1</SettingsVersion>
  <RouterSubAddress>tcp://localhost:10760</RouterSubAddress>
  <FeedbackPubAddress>tcp://localhost:10761</FeedbackPubAddress>
  <DebugPubBind />
  <DebugLogToFile>false</DebugLogToFile>
</Settings>

Router XML
<?xml version="1.0"?>
<Settings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <SettingsVersion>2</SettingsVersion>
  <PsxBoostIP>127.0.0.1</PsxBoostIP>
  <PsxServerIP>127.0.0.1</PsxServerIP>
  <PsxServerPort>10747</PsxServerPort>
  <RouterPubBind>tcp://*:10760</RouterPubBind>
  <FeedbackSubBind>tcp://*:10761</FeedbackSubBind>
  <MinWeightModelOffsetM>4.4</MinWeightModelOffsetM>
  <PrimaryP3DMachineName />
  <DisableRadioInjection>false</DisableRadioInjection>
  <DisableTransponderInjection>false</DisableTransponderInjection>
</Settings>


Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #3 on: Sun, 8 Nov 2020 05:51 »
WILL SOMEBODY PLEASE HELP ME HERE? >:(

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 12091
    • Aerowinx
Re: PSX.NET P3D ExternalSim is not working
« Reply #4 on: Sun, 8 Nov 2020 06:05 »
The correct question is: "Does anybody know a solution?"

When nobody knows a solution, it's not ignorance towards your person; it just means nobody knows a solution.


How to upload forum images is described here:
http://aerowinx.com/board/index.php?topic=1744.0

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #5 on: Mon, 9 Nov 2020 05:26 »
Thanks Hardy.

Mike

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #6 on: Mon, 9 Nov 2020 05:33 »
Below is the Router Box display alongside copies of my simconnect file (in the P3Dv4 app data folder), the P3Dv4 xml file and Router config xml file.

Hopefully these will enable somebody to steer me in the right direction to solve this PITA problem.



Thanks (in advance)

Mike

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 12091
    • Aerowinx
Re: PSX.NET P3D ExternalSim is not working
« Reply #7 on: Mon, 9 Nov 2020 05:54 »
... the P3D aircraft appeared to have only the starboard main gear deployed whilst on the ground, all others were retracted. In the air only the left side gear would retract.

Is this the problem you want to solve?

Does it affect the normal out-of-the-windshield view when using P3D as a PSX windshield?

I'm not an add-on expert; I'm just asking as a forum moderator that wants to highlight the essential part of the text.


|-|ardy

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #8 on: Mon, 9 Nov 2020 06:03 »
Hi Hardy,
I am unable to get PSX to talk to P3Dv4 aircraft using the PSX.NET External Sim add-on. Part of that is that I will get P3Dv4 scenery.
The text that you highlight is part of what I thought might be a symptom but I now think that that problem is possibly another issue.
The main problem is the interactiohn between PSX and P3Dv4.

Regards

Mike

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 12091
    • Aerowinx
Re: PSX.NET P3D ExternalSim is not working
« Reply #9 on: Mon, 9 Nov 2020 06:23 »
Part of that is that I will get P3Dv4 scenery.

"Get" means you get a plausible P3D windshield view from the PSX flightdeck? That is, when PSX is in Greenland, the view shows Greenland, and when PSX banks to the left, the view banks to the left?

Is that the case?


|-|ardy

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #10 on: Mon, 9 Nov 2020 06:37 »
Precisely.
I can get the scenery no problem by configuring the size of the layouts and having the P3D view from the aircraft cockpit behind it. But PSX does not control the dummy (P3Dv4) aircraft which would make the scenery that I see real to the PSX aircraft.

Mike

joergalv

  • Join date: Sep 2014
  • Posts: 69
Re: PSX.NET P3D ExternalSim is not working
« Reply #11 on: Mon, 9 Nov 2020 07:35 »
Mike,

you might want to check the following:

1. In the same directory where your SimConnect.xml resides, you should find an 'add-ons.cfg' file.
This needs to show an entry for the ExternalSim Add-On like the following.

[Package.xx]
Path=C:\Users\[your username]\Documents\Prepar3D v4 Add-ons\PSX.NET.P3D.ExternalSim
Active=TRUE
Required=FALSE

If it's not there, just add the 4 lines with the relevant adjustments for your setup (i.e. package number xx and username)
 
2. In your SimConnect.xml, just before the last line </SimBase.Document> you could add:

  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>local</Scope>
  </SimConnect.Comm>

I have no clue whether this is required, or makes a difference, but I have it in my SimConnect.xml - which definitely works - and it shouldn't harm.

Joerg

Aonang

  • Join date: Jul 2017
  • Location: Krabi, Thailand
  • Posts: 57
Re: PSX.NET P3D ExternalSim is not working
« Reply #12 on: Mon, 9 Nov 2020 08:16 »
Jeorg,

You're a genius, that has fixed it!

Thank you very much!

Unfortunately I have a whole year to wait for the next World Flight now  :(.
Plenty of time for practice ;D

joergalv

  • Join date: Sep 2014
  • Posts: 69
Re: PSX.NET P3D ExternalSim is not working
« Reply #13 on: Mon, 9 Nov 2020 08:25 »
Perfect! Glad it's sorted.

Joerg