News:

Precision Simulator update 10.175 (29 May 2024) is now available.
Navburo update 13 (23 November 2022) is now available.
NG FMC and More is released.

Main Menu

USB controls disconnected during Aerowinx START

Started by double-alpha, Sun, 26 Jan 2020 22:08

double-alpha

Hi Hardy,

I get the message "USB controls disconnected" during the Aerowinx start.

I checked USB selected ON (Preferences/USB/USB on)
I have also this message: No usable USB device found

I use windows 10 and PSX 10.94

My joystick is a Thrusmaster HOTAS WARTHOG; it works well with other simulator.

I have never experienced this trouble with PSX.

I tried to disconnect and plug the Thrustmaster to another USB port, but no joy

Thank you

Hardy Heinlin

Hi, what did you change in your setup before the problem occured?


|-|ardy

double-alpha


Hardy Heinlin

Did another automatic Microsoft Windows 10 Update change anything in your setup?

Are your USB wires fully intact?


|-|ardy

cagarini

Although not PSX-related, last week / weekend Win 10 update did trigger some USB problems at our datacenter.

Some peripherals stopped working or exhibited strange behaviour.

Make sure your desktop isn't on hold for the update, or actually did the update.

Also find how to prevent specific drivers from being updated whenever Win 10 updates automatically. There are many articles available on it accross the Internet - I'll try to find one that was of great use to me when Win 10 updates kept messing around with my Nvidia drivers...

double-alpha

I will check if windows update messed up my USB.

The strange thing is my thrustmaster works pretty well with all my other simulators and games!!! (Therefore I guess my USB wires are fully OK)

Ton van Bochove

Ton

Cappa

Hi Hardy

I have been having the same issue with my PC, Win 10 x64.

PSX starts with USB controls disconnected

I have been trying to resolve the issue for the last day with no success.

I even pulled out the original PSX Install disk, with no luck.

Regards

Joe Somma

Hardy Heinlin


double-alpha

I will watch it all quietly when I have a little more time.
I come back from training, and I haven't used psx for a few months so it could be this windows bug

cagarini

#10
Some basic some maybe useless, but also few good to know suggestions in this article, particularly Method 4

https://www.online-tech-tips.com/computer-tips/usb-device-not-recognized/

There's also another interesting source of information on how to specify which driver updates should not take place when Windows 10 updates take place:

https://www.windowscentral.com/how-disable-automatic-driver-updates-windows-10

Britjet

I find I usually have to uncheck some of power management options as per "method 4" after every windows update.
Otherwise my touchscreens go to sleep.
Peter.

double-alpha

#12
Hi all

I have tested several things (e.g ''method" 4),  my usb works correctly, except with psx (only).
Maybe there is a problem with java.

Joe Somma, If you ever find a solution, keep me informed!

Thank you

Hardy Heinlin

Did you update your Java since your USB worked the last time?

What's in your Aerowinx/Logs/errors.txt?


|-|ardy

double-alpha

#14
I'm not at home for a few days, I will check later...

I can't remember for Java and its update, as I have been away for a while (787 type rating course!).

I have just noticed that my thrustmaster no longer worked with when I returned at home. There should indeed have been a Java update.

By the way, is there a chance to try an older Java update???

cagarini

If you have access to your thrustmaster drivers, or can even fetch the latest version from the site, that could help.

It can also be something you plugged into another USB port ? A Hub ? An external disk ? Headphones ? A wireless mouse ?

There are many quirks with Win 10 updates and I seriously believe this is all more related to that than to Java or even less PSX, although it's true that the way PSX identifies controllers has some limitations, because while in other games like X-Plane, ELITE and IL.2 Great Battles I can easily plug and unplug a new device ( usually my EdTracker set ), whenever I do so PSX assignements go wonky and I have to reset them all...

Cappa

Hi Guys

I tested my Joystick with PSX running on my Macbook, and there are no issues there.

I have tried a few options suggested above with no success.

I have posted below the Logs Errors

[Aerowinx Precision Simulator - Exceptions]

java.lang.NullPointerException
   at net.java.games.input.RawMouse$Button.<init>(RawMouse.java:197)
   at net.java.games.input.RawMouseInfo.createControllerFromDevice(RawMouseInfo.java:83)
   at net.java.games.input.RawInputEnvironmentPlugin.createControllersFromDevices(RawInputEnvironmentPlugin.java:160)
   at net.java.games.input.RawInputEnvironmentPlugin.enumControllers(RawInputEnvironmentPlugin.java:176)
   at net.java.games.input.RawInputEnvironmentPlugin.<init>(RawInputEnvironmentPlugin.java:123)
   at net.java.games.input.DirectAndRawInputEnvironmentPlugin.<init>(DirectAndRawInputEnvironmentPlugin.java:46)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
   at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
   at java.lang.reflect.Constructor.newInstance(Unknown Source)
   at java.lang.Class.newInstance(Unknown Source)
   at net.java.games.input.DefaultControllerEnvironment.getControllers(DefaultControllerEnvironment.java:157)
   at Usb.init(Usb.java:2273)
   at Core.startAll(Core.java:775)
   at Aerowinx.main(Aerowinx.java:65)

Regards

Joe

Steve Hose

Hi Double-alpha and everyone,

Are your USB ports USB 3.0? If yes, there is a known issue with some joysticks and the Intel implementation of USB 3.0 on some motherboards.

Something you can try is to go into the BIOS and check the USB config settings. Look for something called Intel xHCI mode and disable this. This will revert the system back to USB 2.0.

Reboot, reinstall your drivers and see if this resolves the issue.

Regards, Steve.

Hardy Heinlin

Hi Joe,

do you start PSX with AerowinxStart.jar?

If so, please load the file Aerowinx/Preferences/Default.pref with a text editor and search for this variable:

UsbUnknownIncl

If it is set to 1, replace the 1 with 0:

UsbUnknownIncl=0

Save the file. Restart PSX.

According to your errors.txt, the USB system in PSX detects the mouse as a "USB flight control" and the mouse delivers no device data. If it's in the "Unknown USB" category it can be excluded by setting UsbUnknownIncl=0 (which is the default setting, but maybe you changed it for special reasons?).


Regards,

|-|ardy

Cappa

#19
Hi Hardy

Thank you so much for your response, so as you requested i checked the file and it indicated the following

UsbUnknownIncl=0

So one thing i didnt try, i have a wireless mouse which can also be plugged into USB.

I unplugged the mouse from the USB and its actually resolved the issue. so it has something to do with my wireless moused used in USB Mode.

So i have setup the mouse in Bluetooth mode with the same issue.

Its only when i completely disconnect the mouse Bluetooth or wired that the issue seems to resolve.

So its something to do with my mouse and Win 10

Regards

Joe Somma