Welcome, Guest. Please login or register.
Did you miss your activation email?

News:
Precision Simulator update 10.134 (22 April 2021) is now available.
Aerowinx NG FMC and More is now released.

Author Topic: PSX.NET.vPilot  (Read 5111 times)

Mark

  • Join date: Nov 2014
  • Posts: 368
PSX.NET.vPilot
« on: Sat, 30 Dec 2017 22:00 »
Hello all,

I've written a plugin for vPilot that will insert the appropriate VATSIM traffic into the PSX TCAS.

Now available for beta testing:
Download here

To install
Extract and copy the 'PSX.NET.vPilot.dll' file inside the ZIP to:
%localappdata%\vPilot\Plugins

If your PSX server is on a different computer, install the plugin, run vPilot, then close vPilot after 10+ seconds. Then go to this directory which contains the XML settings file where you can edit the PSX server IP within:
%appdata%\PSX.NET\PSX.NET.vPilot

(If you're unsure how to use the % paths, just copy it into the File Explorer address bar and hit enter)

Please let me know how well it works. When working, it'll look like this (link).

ScudRunner

  • Join date: Apr 2013
  • Location: YBBN
  • Posts: 134
Re: PSX.NET.vPilot
« Reply #1 on: Sat, 30 Dec 2017 23:48 »
Many thanks Mark!

kev32b

  • Join date: Oct 2014
  • Posts: 96
Re: PSX.NET.vPilot
« Reply #2 on: Sat, 30 Dec 2017 23:59 »
Mark

Thanks for your hard work
And for your excellent software
Kev

Britjet

  • Join date: Aug 2014
  • Location: Camberley, UK
  • Posts: 1541
Re: PSX.NET.vPilot
« Reply #3 on: Sun, 31 Dec 2017 12:25 »
Thanks Mark!
Peter.

SIMU-3G7

  • Join date: Apr 2013
  • Location: CYQB
  • Posts: 29
Re: PSX.NET.vPilot
« Reply #4 on: Sun, 31 Dec 2017 18:52 »
Thanks a lot Mark.

Cheers

Gilles-Gabriel  8)
Up There With The Best Of The Best...

kev32b

  • Join date: Oct 2014
  • Posts: 96
Re: PSX.NET.vPilot
« Reply #5 on: Tue, 2 Jan 2018 07:27 »
Hi,

If you are running Vpilot on two machines ie host and remote it needs to go on the Host Machine .

Works lovely
Kev

(only issue is when closing it the program you cant it wont shut down !!)

Mark

  • Join date: Nov 2014
  • Posts: 368
Re: PSX.NET.vPilot
« Reply #6 on: Tue, 2 Jan 2018 17:09 »
(only issue is when closing it the program you cant it wont shut down !!)

If you mean you're trying to close the TCAS window - this is intended behaviour as there is no easy way to respawn it again without restarting vPilot. Closing vPilot should work as normal.

Jeroen Hoppenbrouwers

  • Moderator
  • Join date: May 2009
  • Location: KTMB
  • Posts: 4173
  • Hoppie designs avionics equipment for airliners.
    • http://www.hoppie.nl/
Re: PSX.NET.vPilot
« Reply #7 on: Tue, 2 Jan 2018 23:08 »
I know it is nearly whining, but a popup explaining why this window won't shut down may actually be helpful. It's sufficiently counter-intuitive.


Hoppie

farrokh747

  • Join date: May 2009
  • Location: Mumbai, India
  • Posts: 922
    • http://www.farrokhchothia.com/
Re: PSX.NET.vPilot
« Reply #8 on: Wed, 3 Jan 2018 04:23 »
Thanks Mark!

Flex

  • Join date: Feb 2016
  • Posts: 128
Re: PSX.NET.vPilot
« Reply #9 on: Sat, 13 Jan 2018 17:27 »
Forgive my ignorance, does this mean I can use PSX naively without P3D and still have VATSIM traffic injected into PSX?

 

Mark

  • Join date: Nov 2014
  • Posts: 368
Re: PSX.NET.vPilot
« Reply #10 on: Sat, 13 Jan 2018 21:08 »
Felix - not yet, vPilot still has to make a connection to P3D so that it can get the position & other data.

The aim is to eventually resolve this so that P3D is optional for PSX vatsim users if you're happy with just the PSX generated view.

Markus Vitzethum

  • Join date: May 2009
  • Location: Reutlingen, Germany (near EDDS)
  • Posts: 405
Re: PSX.NET.vPilot
« Reply #11 on: Thu, 5 Jul 2018 20:50 »
Hello Mark,

having missed the topic in earlier in winter this winter, I gave it try myself tonight. First of all, great nice little program, thank you very much.

Actually, it took some debugging on my side.

Minor issue:
- install the .dll into the vPilot program folder (Plugins subdirectory) and not in the %localappdata% folder. At least on my system, they are different

Not so minor issue:
- after adjusting plugin path and editing the dll, the TCAS plugin recognized and connected to PSX. But I could not see TCAS traffic inside PSX, yet. It took me a while to recognize that I have solved this problem earlier with TrafficPSX, see

http://aerowinx.com/board/index.php?topic=2321.msg23105#msg23105

Like in 2014 I have monitored the Qs450 output of the DLL in a telnet client. Same result.

The problem is that the PSX.net TCAS dll is using the (Windows) system decimal seperator which may be either "," (comma) or "." (decimal point) on different systems. But PSX is using a fixed decimal seperator which is a decimal point but never a comma.

Changing the system decimal seperator on my German language Windows usually has side effects (breaks MS Excel, ... ).

The better solution - programming-wise - is to use a fixed decimal seperator in your program code (most languages have a system variable for that), e.g. like

DecimalSeparator := '.';

This would be a permanent stable solution, it worked well for VisualPSX.

Thanks,
  Markus
« Last edit: Fri, 6 Jul 2018 22:05 by Markus Vitzethum »

Greg Hateley

  • Join date: Aug 2011
  • Location: Perth
  • Posts: 87
Re: PSX.NET.vPilot
« Reply #12 on: Mon, 9 Jul 2018 06:01 »
I used this program with Vpilot on the wekend with great success.

Thanks Mark for another great program.

Markus Vitzethum

  • Join date: May 2009
  • Location: Reutlingen, Germany (near EDDS)
  • Posts: 405
Re: PSX.NET.vPilot
« Reply #13 on: Mon, 9 Jul 2018 12:51 »
Same here, I flew a VATSIM event (Kai Tak!) with plenty of airplanes to watch (cockpit window and TCAS on the ND) in plenty of holding patterns.

Greg, you might have noticed my TCAS blip in the ABBEY/ALPHA holding pattern. I left the stack just as you entered, I think.

Markus

p.s.
turning in a holding pattern back to the fix when one enters 1000' below and, simultaneously, another 1000' above you - priceless.
« Last edit: Tue, 10 Jul 2018 08:54 by Markus Vitzethum »

farrokh747

  • Join date: May 2009
  • Location: Mumbai, India
  • Posts: 922
    • http://www.farrokhchothia.com/
Re: PSX.NET.vPilot
« Reply #14 on: Thu, 30 Aug 2018 14:21 »
Hi

my vpilot is on a remote pc to PSX - installed the dll in the plugins folder, started vpilot and shut it after apx 15 sec

edit: The little tcas/traffic window opens, says not connected to PSX

http://farrokhchothia.com/slists/vatsim/vpilot2.JPG

http://farrokhchothia.com/slists/vatsim/vpilot1.JPG

this generates  a PSX.NET folder in /roaming and the xml, but it is an empty file.... there's no text in it....

any idea what im doing wrong?

fc
« Last edit: Fri, 31 Aug 2018 06:29 by farrokh747 »

Markus Vitzethum

  • Join date: May 2009
  • Location: Reutlingen, Germany (near EDDS)
  • Posts: 405
Re: PSX.NET.vPilot
« Reply #15 on: Sat, 12 Oct 2019 11:14 »
Hi all,

with the latest vPilot release for AFV (2.3.x. branch), the PSX.net vPilot plugin refused to load on my P3D machine. .... While typing the error report, I have already solved the issue.

This is the vPilot debug log:
[11:44:07.027] Error loading plugin from file "D:\Programme\vPilot\Plugins\PSX.NET.vPilot.dll": Die Datei oder Assembly "file:///D:\Programme\vPilot\Plugins\PSX.NET.vPilot.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Der Vorgang wird nicht unterstützt. (Ausnahme von HRESULT: 0x80131515)


which translates to
Could not load file or assembly 'file:///D:\Programme\vPilot\Plugins\PSX.NET.vPilot.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)

The solution is given here:
https://blogs.msdn.microsoft.com/brada/2009/12/11/visual-studio-project-sample-loading-error-assembly-could-not-be-loaded-and-will-be-ignored-could-not-load-file-or-assembly-or-one-of-its-dependencies-operation-is-not-supported-exception-from/

Because the file PSX.Net.vPilot.dll was downloaded from the internet, it was flagged as "unsecure" by Windows. This was not an issue in vPilot 2.2 but apparently is now in 2.3. To solve the problem, right click on the dll and change the security setting to "Allow" (my system) or "Unblock".

Markus



ScudRunner

  • Join date: Apr 2013
  • Location: YBBN
  • Posts: 134
Re: PSX.NET.vPilot
« Reply #16 on: Sun, 13 Oct 2019 04:21 »
Many thanks Markus... I wondered what might have happened to cause this. Running fine here now .

Britjet

  • Join date: Aug 2014
  • Location: Camberley, UK
  • Posts: 1541
Re: PSX.NET.vPilot
« Reply #17 on: Mon, 14 Oct 2019 15:05 »
This fix doesn’t work for me - I have all the rest of the new voice working but still getting the error on loading the dll, I’m afraid...:-(

Edit - fixed it! I was trying to do it all under the “Security” Tab in properties but the unblock feature is in the “General” Tab.

Thanks Markus!
Peter

Markus Vitzethum

  • Join date: May 2009
  • Location: Reutlingen, Germany (near EDDS)
  • Posts: 405
Re: PSX.NET.vPilot
« Reply #18 on: Tue, 15 Oct 2019 09:45 »
Glad that it worked for you guys and helps you to run the TCAS module again.

Markus

Martin Baker

  • Join date: Jul 2014
  • Location: UK
  • Posts: 248
Re: PSX.NET.vPilot
« Reply #19 on: Tue, 16 Feb 2021 21:21 »
This plug-in seems no longer to work using the latest version of vPilot. I wondered why and found this thread - see the final post: https://forums.vatsim.net/topic/24636-vpilot-plugin-developmentdebugging/

Is anyone able to help?

Thank you,

M