Precision Simulator update 10.175 (29 May 2024) is now available.
Navburo update 13 (23 November 2022) is now available.
NG FMC and More is released.

Main Menu

WidePSX 2.5.9 : FSX, P3D and MSFS Compatible Scenery Generator Bridge

Started by JP59, Fri, 8 Dec 2017 16:17


Quote from: B747-400 on Fri, 25 Feb 2022 10:08
Regarding the lights:
(..) I tweaked the systems.cfg, and now all lights are working, I can switch all lights with PSX. Most important, the taxi and landing lights. I don't know, if my approach is correct in regard of how it is intended from MS to work. But for me, I got what I want: working lights with my switches in the sim.

would you mind sharing your solution?



a bit complex, here some backgrounds why:

first of all, I edited the original asobo 747-8i, but recognized: each update overwrites my changes. So, that's not practicable.

Then I tried different 3rd party planes to recognize: they are different in handling the lights.

I could not find a suitable 400 for MSFS out there. The obvious solution, the mentioned Posky, is nowhere to find.

So, I found a 747-8 on But the lights are working different, as soon as you install some light updates, instead of using the MSFS ones.

WidePSX handles the lights different, than the new MSFSPSX Bridge from Stephan. With WidePSX they are not switchable individually. In MSFSPSX they are ... BUT ... you need to edit the config files in two different ways for each of the bridges, if you are going to use an 3rd party plane.

Why do i use a 3rd party? Well, I do not want to see any virtual cockpit, as I am sitting in my fullsize cockpit. So: I edited the 3rd party plane, to get rid of the cockpit, and the externals, as soon as I am inside the plane. BUT ... without a 3rd party light update, you won't see the MSFS standard light as well from inside, because it's an external thing.

Why am I forced to remove the externals when inside the cockpit? Well, because you still see the wipers and cockpit window frames from inside, because they belong to externals...

Crazy stuff ...  :o :o

Not sure if you are still interested, but that are the facts, and my outcomes of days of tweaking "in short words".



Thanks so much for making this freeware! Sorry if I missed it but is there a link where we can voluntarily leave donations to support your work. I'm sure Hardy wouldn't mind.

Take care

I got my first copy of PS1@13. I am 35 and own PSX. I don't think I will ever fully grasp the intricacies and engineering of this manmade structure It transcends a 'machine/vehicle'.I think if AI were to become sentient it would have happened already by now (pick your favourite post 1980s airliner)


Hello all. Ever since switching to WidePSX 2.5.8 (paired with MSFS 2020), I don't seem to see the MSFS traffic being injected into the PSX simulator. Just wondering if anyone else is experiencing the same issue.



Hi JP59,

First of all, thank you for your efforts! I tried using external pushback tool  (Ambitious Pilots) but for the life of me I cannot get PSX to follow. Latest versions of WidePSX and pushback tool used. I follow the below procedure -

1. Start MSFS, load Asobo's 748 onto EGPH Gate 9
2. Start PSX, load Basic 003 situation (On ground and cleared for engine start)
    2a. Change situation position to EGPH
3. Start WidePSX
    3a. Connect
    3b. Start Scenery Generator Bridge with PSX as slave
    3c. Check for Taxi Lights OFF and Fuel Cut Off 1 to OFF
    3c. Start Gnd Services Module (Ready for push back scenario). Note: Use  of external pushback selected.

4. Initiate pre planned pushback in the Ambitious Pilots mod. I wait for the instruction to release brakes and the pushback commences however, PSX remains in place.

Thanks in advance!




I saw that issue yesterday leaving CYVR Gate 75, but it worked OK the next time. Today, the pushback worked initially but not the next time. Also, I was getting double or triple voice commands from Toolbar Pushback (until the plane started moving). However, once I turn the taxi lights ON, MSFS does not stay where it was. It jumps to where PSX thinks it is (PSX set as slave). I'm using FSDT CYVR in MSFS. Not sure if that's affecting things. Also, WidePSX seems to loop at 'Permit the Ground Engineer to disconnect...'.



Thanks Randy. I am not even sure I am using the tool correctly as the documentation is slightly vague on interaction with the external taxi mod and how exactly to trigger the process with fuel cutoff 1 switch etc. Does one still need to initiate the pushback by pressing the PTT whilst dialled into FLT on ACP panel? I assume not.




I believe the pushback is initiated through Toolbar Pushback in MSFS and PSX is supposed to track the position of MSFS until the taxi lights and fuel cutoff #1 are turned ON in PSX, then MSFS scenery should follow PSX, but it isn't working for me. You can use the Flt comms to simulate/advance the dialog in WidePSX but it doesn't make sense if you are using the voice option in Toolbar Pushback. And, as I mentioned, it loops when you get to the disconnect dialog at the end.

It's entirely possible I'm doing something wrong as well. I'll play with it some more. Oh, and the duplicate dialog from Toolbar Pushback is a known issue, possibly caused by too much AI traffic in MSFS.



I tried another pushback. PSX did not follow MSFS, but going through the dialog using the FLT interphone, PSX began moving (I think after "Release Parking Brake"), but it didn't end up where the plane was in MSFS, and once I turned on the Taxi Light after engines were running, MSFS jumped to where PSX was.

I guess the external pushback system isn't currently compatible with WidePSX.



I just tested using P3Dv5 and GSX and I had the same issue - PSX would not follow the P3D pushback and basically did its own thing. Then P3D jumped to the PSX position upon Taxi Lights ON. So it's not an MSFS issue.



Hello All,

Sorry for the late reply. I am away from flight simulation since a while now. I read your comments about the pushback issue. From what I remember, the key thing is to load the aircraft Cold & Dark or at least with engines, Taxi lights and Beacon OFF. I think the process is armed when the Beacon is turned ON, and released when the Taxi light switch is turned ON (be sure to have the "Taxi light switch" option turned ON in the PSX aircraft's equipment page). Then the process is reset for a new flight sequence when the FUEL CUTOFF 1 is set to 0 at the end of the flight. So the sequence should be :

- Make sure PSX has Taxi Lights OFF / Beacon OFF / FUEL CUTOFF 1 OFF before connecting WidePSX

- Check that the "Use of external pushback" option is activated on the Ground Services Tab (checkbox must be checked) and connect WidePSX. Follow the real world SOPs (Beacon ON before starting the pushback / Then start pushing back using MSFS' pushback module by Ambitious Pilots then switch the Taxi Lights ON at the end of the pushback, before to start taxiing)

- Never use PSX's own pushback system when "Use of external pushback" option is checked in WidePSX, it will lead to a big mess

If it still doesn't work, I sugest disabling the "Use of external pushback" option in WidePSX (Ground Services Tab) and use PSX's or WidePSX's "standard" pushback system. I will do some tests when able.

Best regards,


Hi Jean-Philippe,

I'm pretty sure that is the procedure I used but will try again to be sure and report back. Also, I assume the Ground Services module needs to be started?




I tested again and have the same issue, If I monitor the Situation/Position in PSX during the pushback it does seem to be moving, but for some reason it's not ending up where MSFS thinks it is, almost as if there is a problem with the lat/lon precision, e.g N49 11.2 W123 10.1 when it should be N49 11.1842 W123 10.1223 (just making this up as it isn't always the same spot that it jumps to), and the final heading is wrong as well. For reference, I'm using CYVR Gate 74.



Hi Randy,

Thank you for your feedback. Of course both Scenery Generator and Ground Services Modules need to be started. Maybe something has changed with the recent MSFS or Ambitious Pilots pushback system updates (the feature was working perfectly during my pre-release tests). I will do some tests when able, but I can't promise when.

Best regards,


No worries, Jean-Philippe, it's perfectly usable with the PSX pushback. I suspect you are correct in that something changed on MSFS side.

All the best,


With the recent MSFS update, the landing and taxi lights no longer work. I am using the POSKY 747-400 model. Any ideas on how to fix?


I noticed a similar behavior a while ago (probably around the World Update 5 or 6) and assumed, something in my procedure was wrong. (POSKY 747-400 for me as well)

Here's my startup routine, maybe it's helpful for you:
- PSX is loaded at the gate (with engines off)
- MSFS is loading the aircraft at the departure runway (with engines running)
- then I connect WidePSX with MSFS as slave (MSFS jumps to PSX position)
[switch to exterior view to see what happens]
- about 20-30s after connecting PSX and MSFS, the Nav-Lights in MSFS go off (MSFS engines are now off)
- switch on the batteries in MSFS ("Toggle Master Battery"; keyboard shortcut Alt+B for me)
Now the Nav-Lights in MSFS are back on and all other lights are working too.

After arriving at the gate and switching off the engines, the lights will remain to operate normal, and in exterior view I can see the MSFS engines still running. If you use the WidePSX ground simulation and wish to perform another flight, you'll have to restart WidePSX and reconnect (then the MSFS engines will shut off and the whole thing with lights going off starts new).
I have to do this all the time after I connect to WidePSX, but it's acceptable for me with having the shortcut. My current MSFS is
I don't know, if my routine is the originally intended one, but it's flesh and blood now.

Best Regards,


Thanks Sebastian, I do everything you do apart from switching on the batteries in MSFS. I'll give that a try on my next flight  :D


Anyone use Realtraffic/PSXseeconTraffic? The traffic appears fine in MSFS but doesn't show up in PSX. i have the traffic checkbox ticked in WidePSX.


Quote from: GodAtum on Mon, 30 May 2022 12:21
Anyone use Realtraffic/PSXseeconTraffic? The traffic appears fine in MSFS but doesn't show up in PSX. i have the traffic checkbox ticked in WidePSX.
PSXT does not work for PSX. You should use RealTraffic directly to inject Traffic in PSX. However,  It will not -like PSXT - spawn ai aircraft in MSFS.