Welcome, Guest. Please login or register.
Did you miss your activation email?

News:
Precision Simulator update 10.132 (14 February 2021) is now available.
Aerowinx NG FMC and More is now released.

Author Topic: Is the latest Java version useable?  (Read 17215 times)

farrokh747

  • Join date: May 2009
  • Location: Mumbai, India
  • Posts: 919
    • http://www.farrokhchothia.com/
Is the latest Java version useable?
« on: Mon, 29 Jun 2015 06:50 »
Hi Jan

Im using 10.9.5 (MBP Retina), and I had problems with java update 45 - i have gone back to update 31, and everything works fine -

There was an issue with the MBP Retinas, but that was solved (for me) by installing the JDK as well..

hope this helps,

fc


Edit HH. Split topic for latest updates.
« Last edit: Sat, 22 Aug 2015 00:54 by Hardy Heinlin »

godot

  • Join date: Jul 2015
  • Posts: 7
Re: Problems with latest Java version?
« Reply #1 on: Fri, 3 Jul 2015 13:30 »
Coincidentally, I've had severe problems with java versions higher than 1.8.0_31 with another software project (Tigase XMPP server running on Solaris x64). Although this doesn't say anything about its suitability for PSX, it establishes a trend that these newer java versions are ... dodgy.

B747-400

  • Join date: Nov 2010
  • Location: Vienna
  • Posts: 241
    • http://www.b747-400.net
Re: Problems with latest Java version?
« Reply #2 on: Fri, 3 Jul 2015 13:38 »
Hi

using Ver. 8 Upd. 31 (Build 1.8.0_31-b13) here ... rock solid ... no probs at all!

BR Hans
Hans G. Schuetz
http://B747-400.net

honzavlk

  • Join date: Sep 2014
  • Posts: 18
Re: Problems with latest Java version?
« Reply #3 on: Mon, 6 Jul 2015 21:08 »
Hi,

sorry for late reply.. I didn't have time to check it earlier..
I have just installed 10.0.5 (with new interfaces).. it told me still to install java besides i have the latest java installed. I checked java forum about this problem (program in OS X Yosemite requires java install but latest java is installed).. Solution is to install some kind of java package from apple (Java for OSX 2014-001).. So i did it.. I am now able to start PSX.. great progress.. but.. i think there is some problem (maybe conflict of the "two" java versions installed?).. FPS are very low.. around 21 fps.. (iMac with i5 and intel iris pro).. i have no problem running psx on my laptop (worse hardware config) with on board graphics around 72 FPS as usually..
and finally.. the MCP panel texture is missing somehow.. i really haven't seen this thing ever..  the PSX graphics is corrupted in certain areas )when i resize panel windows it gets stuck so the green lines dividing individual panels are everywhere.. I think it must be a java problem as PSX does not have its own "engine"..

I have copy of my PSX on my macbook air and i don't have these problems as i am having right now on the iMac.. Really strange.

Anyone has problems running PSX on OS X Yosemite ?

Jan
 
Quote from: Hardy Heinlin

Hi Jan,

please don't start PSX by clicking on Aerowinx.jar -- that will never work.

What version of PSX are you using?

And: Are you using the old or the new Interfaces? See http://aerowinx.com/forum/topic.php?id=2841


Regards,

|-|ardy

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 12207
    • Aerowinx
Re: Problems with latest Java version?
« Reply #4 on: Mon, 6 Jul 2015 21:36 »
Hi Jan,

you shouldn't use Java 1.8 update 45 if your MCP graphics are not correctly rendered or if your frame rate has dropped from 60+ to below 30. That's the typical problem of the buggy Java 1.8 update 45 on the Mac.

You need to install a lower Java update. See the posts above for some hints:

http://aerowinx.com/forum/topic.php?post=28241#post28241


Regards,

|-|ardy
« Last edit: Mon, 6 Jul 2015 21:37 by Hardy Heinlin »

honzavlk

  • Join date: Sep 2014
  • Posts: 18
Re: Problems with latest Java version?
« Reply #5 on: Mon, 6 Jul 2015 21:37 »
It doesn't work on my macbook air as well anymore.. But it used to work quite perfectly.. there must have been some "update" that is causing this problem..

J.

honzavlk

  • Join date: Sep 2014
  • Posts: 18
Re: Problems with latest Java version?
« Reply #6 on: Mon, 6 Jul 2015 21:38 »
Hi,

thanks.. will try to find some older version..

Jan.

Quote from: Hardy Heinlin

Hi Jan,

you shouldn't use Java 1.8 update 45 if your MCP graphics are not correctly rendered or if your frame rate has dropped from 60+ to below 30. That's the typical problem of the buggy Java 1.8 update 45 on the Mac.

You need to install a lower Java update. See the posts above for some hints:

http://aerowinx.com/forum/topic.php?post=28241#post28241


Regards,

|-|ardy

farrokh747

  • Join date: May 2009
  • Location: Mumbai, India
  • Posts: 919
    • http://www.farrokhchothia.com/
Re: Problems with latest Java version?
« Reply #7 on: Tue, 7 Jul 2015 05:32 »
hi

http://www.oracle.com/technetwork/java/javase/archive-139210.html

for older versions -

In my case, update 45 caused issues.. I have gone back to _31 and it works fine - You may also have to install the JDK (update 31) as well, along with the JRE

MBP Mavericks

hope this helps

fc

Sylle

  • Join date: May 2010
  • Location: Brussels, BE
  • Posts: 151
    • PSX Micro-Addon repository
Re: Problems with latest Java version?
« Reply #8 on: Thu, 16 Jul 2015 12:10 »
Java 8 build 51
- works on my windows 8.1 pc
- does NOT work on my windows 7 pc (hangs at 79% with error 'exception in thread main')

Regards,
Sylvain
« Last edit: Thu, 16 Jul 2015 12:11 by Sylle »

Jeroen D

  • Join date: May 2009
  • Posts: 619
Re: Problems with latest Java version?
« Reply #9 on: Mon, 10 Aug 2015 16:33 »
Gents,
I need to get rid of the Java 8 _45 as my Mac has developed some issue with it. Can anybody provide me with a step by step procedure how to go about it? I have looked around the web, but I don't understand anything I see out there.

Thanks

Jeroen

joergalv

  • Join date: Sep 2014
  • Posts: 70
Re: Problems with latest Java version?
« Reply #10 on: Mon, 10 Aug 2015 18:04 »
Jeroen,

per the official way published by Oracle you only need to delete the file JavaAppletPlugin.plugin.

To do this:
- Open the Finder
- Select Applications in the left column (i think this is optional)
- Enter JavaAppletPlugin.plugin into the search field (top right)
- Make sure that the search is covering the whole Mac, not only the applications folder
- JavaAppletPlugin.plugin should be found
- Move JavaAppletPlugin.plugin into the Trash

Removing the JDK is described at the bottom of the following link:
http://docs.oracle.com/javase/7/docs/webnotes/install/mac/mac-jdk.html

Hope that helps.
Joerg

btw.: With Java 8_51 i don't see the issues i had with 8_45 on my MBP

Jeroen D

  • Join date: May 2009
  • Posts: 619
Re: Problems with latest Java version?
« Reply #11 on: Mon, 10 Aug 2015 18:24 »
Hi Joerg,
Thanks. First part removing the plug in worked fine!

But I really don't know how to do this last bit to remove the JDK

Quote
To uninstall the JDK, you must have Administrator privileges and execute the remove command either as root or by using the sudo(8) tool.

Navigate to /Library/Java/JavaVirtualMachines and remove the directory whose name matches the following format:*


How do I execute the remove command etc. navigate to etc.

Sorry, feel really stupid, but I have no idea!?
thanks
Jeroen

joergalv

  • Join date: Sep 2014
  • Posts: 70
Re: Problems with latest Java version?
« Reply #12 on: Mon, 10 Aug 2015 19:14 »
Hi Jeroen,

I see the guide from Oracle is made for system administrators, rather then normal users.
No problem though. You can also navigate to the file and delete it using Finder again.

- Open Finder
- locate & left click on the internal disk (Macintosh HD ?) in the left column
- in the right window find the folder Library and open it (left double click it)
- find the folder Java and open it
- find the folder JavaVirtualMachines and open it

Now you can move the folder jdk1.xxxx.jdk to the trash.
(You'll might be asked to provide your password)

Cheers,
Joerg

Jeroen D

  • Join date: May 2009
  • Posts: 619
Re: Problems with latest Java version?
« Reply #13 on: Mon, 10 Aug 2015 20:12 »
Quote from: joergalv

Now you can move the folder jdk1.xxxx.jdk to the trash.
(You'll might be asked to provide your password)



Thanks Joerg,
That seems to have done the trick!! Phew!
I installed the _31 and did a quick check in PSX and at first glance everything is back to normal. I'll try my joystick and numpad later this week.

Glad I got it back to normal operations though.

Thanks for all your assistance, much appreciated!!

Jeroen

joergalv

  • Join date: Sep 2014
  • Posts: 70
Re: Problems with latest Java version?
« Reply #14 on: Mon, 10 Aug 2015 20:32 »
welcome. glad you sorted it out.

Joerg

United744

  • Join date: Oct 2014
  • Posts: 850
Re: Is the latest Java version useable?
« Reply #15 on: Wed, 7 Oct 2015 21:57 »
This thread is a little old; does anyone use the latest (as of October 2015) JDK without problems?

evaamo

  • Join date: Jan 2010
  • Location: MMMX
  • Posts: 239
Re: Is the latest Java version useable?
« Reply #16 on: Wed, 7 Oct 2015 22:28 »
FWIW, I am using JDK 1.8_60 on a MacBook Pro Retina 13.3" (late 2013 model) with no issues at all. This is using the latest El Capitan.

I get better performance when running PSX in no-HiDPI modes (2560x1600). I use the utility rdm to switch display modes.

In addition to that, I have a Windows 10 bootcamp partition using the same display resolution and the same JDK version. Windows leads OS X by ~10% in terms of FPS, nothing to write home about.

Cheers,
-E 
Enrique Vaamonde

jcomm

  • Join date: Dec 2011
  • Location: LPMT
  • Posts: 1562
Re: Is the latest Java version useable?
« Reply #17 on: Sun, 1 May 2016 08:35 »
I was just forced to upgrade to the latest Java version, and running PSX standalone presents no problem, but I did find some quirks I was not experiencing before when running it with either XView or VisualPSX :-/

In X-Plane 10 I had to disable the "Real Terra Haze" plugin, and even the Python-based weather injector :-( and get XView injecting weather directly from PSX.

In FSX:SE with VisualPSX, I notice incompatibility with Active Sky. 

Well, I will probably revert back to the former Java version...

kiek

  • Join date: Jul 2014
  • Location: The Netherlands
  • Posts: 632
    • Live traffic in FSX/P3D
Re: Is the latest Java version useable?
« Reply #18 on: Sun, 1 May 2016 08:45 »
I always update (on Windows 10) immediately. Current version: 8 update 91 (build 1.8.0_91-b14).
No problems noticed (PSX, Visual PSX, RealTraffic).

Nico

jcomm

  • Join date: Dec 2011
  • Location: LPMT
  • Posts: 1562
Re: Is the latest Java version useable?
« Reply #19 on: Sun, 1 May 2016 12:31 »
Thx Nico. Probably any other problem with my install then.