News:

Precision Simulator update 10.175 (29 May 2024) is now available.
Navburo update 13 (23 November 2022) is now available.
NG FMC and More is released.

Main Menu

FiFLi add-on - First officer and Flight attendant for PSX - beta 0.77

Started by vito, Sun, 4 Jan 2015 19:22

pacwest18

Hi Vito,

Thanks for the great add-on.  I recently got a new computer and had to reinstall PSX and FiFLi.  When I load PSX to a cold and dark cockpit setting and then launch FiFLi, I see the connection being made in PSX's network page, but FiFLi doesn't seem to register the connection (i.e., no status is shown such as "Parked at the gate").  The Java launcher has permission to communicate freely on my private network so I'm not sure what else might be the problem.

Was wondering if I'm missing something obvious in my setup.

Best,
S

pacwest18

Problem appears to have resolved itself.  Not sure what happened. I rebooted the machine and relaunched PSX.  FiFLi was able to connect after that.

martin

Quote from: pacwest18Not sure what happened.
Probably a "bit-flip caused by cosmic rays"...
(We know at FL400 or so one is rather exposed.)

Quote from: pacwest18I rebooted the machine
Always the way to go, they do it on Mars these days... (see last two paragraphs)

;)

pacwest18

If it's good enough for a Mars expedition - it's good enough for me :).

vito


RogerH

Hi Vito.

I run a fixed base cockpit with hardware switches etc.

I love the sounds of the cabin, announcements etc. But I don't need the FO to do anything, as this will result in my hardware switches being in the wrong position if he moves one "virtually".

I realise I can uncheck the FO Actions box and therefore he won't do anything. Does this also disable FO sounds like when he says he's going outside?

Also, I use Gary's BACARS add on, with Simbrief planning. This deals with fuel for me as well as passenger load. It sets the ZFW and also gradually fills the fuel tanks. How do I avoid FiFli clashing here? Do I simply set ZFW to 0 , or leave it blank?

Many thanks for your hard work in enhancing our enjoyment of PSX!

Cheers,

Roger.

vito

Hi Roger,

FO active "check" means that you will hear FO voice and he will mess with switches, otherwise you will not hear him and he won't move anything. As for ZFW and Planned fuel fields, if you leave them as they are set (inserted zeroes) FIFLI will not fill your tanks or load passengers via modifying ZFW (but you will still have sounds and timer as virtual passengers are loading).

best regards

vito

RogerH

Thanks for the quick reply Vito. As I'd thought but nice to have it confirmed. Thanks for a great addon :-)

vito


RogerH

Hi Vito,

I tried a test flight last night.

I followed the tutorial as far as possible with the FO inactive.

I found that I could not hear the flight attendants' announcements.

It is probably something trivial but have you come across this before with inactive FO?

Many thanks,

Roger.

vito


RogerH

Yep but I only thought of it halfway through the flight - will try again tonight with it activated from the beginning!

vito

I made few revisions through weekend:

Beta 0.75
Fixed bug: when selected fuel is lower than fuel currently on board, quick refuelling would last forever, now this is reset when boarding is complete.
 
Beta 0.76
Fixed bug: boarding sound now playing according to boarding time

Complete package:
https://www.dropbox.com/s/6dvaovmoy2qt9bc/FiFLi.zip?dl=0

and just "jar" file:
https://www.dropbox.com/s/x7xc080iq0tp6ll/FiFLi.jar?dl=0

FiFLi tutorial can be downloaded here:
https://www.dropbox.com/s/awzpc6p4gb56dtk/FiFLi_tutorial_1.1.pdf?dl=0

If you don't have any problems let me know :-)

bet regards
vito

vito

Quote from: RogerH on Tue, 19 Nov 2019 18:54
Yep but I only thought of it halfway through the flight - will try again tonight with it activated from the beginning!

and also check: did you maybe accidentally lower PA volume to much down ? Then you would not hear PA announcements!

best regards
vito


RogerH

Hi Vito,

PA volume activated and full-power! No sounds.

However, it occurs to me I mihgt have just downloaded the .jar file without the full package - hence FiFli goes through the correct states but has no sound.

I've had a quick look through the thread but all references to the addon are giving broken Dropbox links - can you advise where I can find the full package?

Many thanks,

Roger.

Edit - I think I've found it - when I originally installed I _copied_ FiFli.jar to the desktop insted of putting a shortcut there - hang fire on everything, have now made it a shortcut so the sound files are available. Will report back. I tend to rush at things sometimes and skip important steps - learning PSX will help train me out of that!

Edit 2 - yep, that was it. All sounds playing now. Thanks for your patience!

vito

Few posts ahead I posted update to FiFLi. From there I can download full package from the link. This didn't
work for you ? here is link to full package:

https://www.dropbox.com/s/6dvaovmoy2qt9bc/FiFLi.zip?dl=0

best regards

vito

ps. - I think you just had bad luck: I was uploading new version package at the moment you were trying to download it. Sorry :-)
I just checked: the links in main post of the thread and links are really broken, now they are fixed. Thanks for the tip !


RogerH

Hi Vito no problem!

OK it's starting to come together.

I had lovely noises and announcements up till Runway Entry Procedure - I turned onn the inboard landing lights and FiFli went to REP as expected.

Since I don't have FO active, after a couple of moments I turned on the other landing lights, but forgot strobe... does that matter?

I put strobe on later but only after passing 10k ft - when FiFli did not change to Climb and Cruise and I started looking for reasons - I'm wondering if that is an issue?

Anyway I'm in the cruise now at FL210 with FiFli still in Runway Entry Procedure.

What have I missed?

many thanks,

Roger.

Edit. I'm still recovering from having been quite poorly so I have knocked it on the head for tonight. But thanks for the prompt and friendly help :-) back on it tomorrow!

vito

Hi Roger,

If you forgot "strobe" light then you would not get "before take off procedure". After take off you probably forget to set passenger seat belts sign to auto or off - that's why you probably didn't hear cruise announcement. 

I strongly suggest that  you check FiFLi tutorial:

FiFLi tutorial can be downloaded here:
https://www.dropbox.com/s/awzpc6p4gb56dtk/FiFLi_tutorial_1.1.pdf?dl=0

best regards
vito


RogerH

Hi Vito,

Much to my chagrin I have to say I was following the tutorial, lol!

I just have to be more methodical!

Cheers,

Roger.

RogerH

Tried again last night but after takeoff and passing 10,000 ft, turning the seat belt lights to 'off' after 10k ft, still stuck on Runway Entry Procedure. Went up as far as FL230 and waited for around 15 mins before admitting defeat :-)

I'm theorising that the FO when active is doing something that I am not, having unchecked the 'FO Active' box before starting FiFli.

I followed the tutorial and carried out all the checklists this time - even remembered the strobe!

It'll be something simple I'm sure. Do you have a list of FO actions during and after Runway Entry Procedure that you can let me have? I want to check I carry out everything. Is turning the seatbelt signs to Auto or Off after FL110 the only trigger for changing state to climb/cruise?

Cheers,

Roger..