News:

Precision Simulator update 10.175 (29 May 2024) is now available.
Navburo update 13 (23 November 2022) is now available.
NG FMC and More is released.

Main Menu

Two Addons: AdaptPSX and SimSwitch

Started by John Golin, Mon, 11 Aug 2014 08:54

John Golin

Thanks to Garry Richards for hosting on his site!

http://flightsim.garryric.com/

AdaptPSX Beta 1

AdaptPSX is a Java application that provides a suite of small but useful additional functions to PSX, as well as an interface for the Aerosoft MCP and the Engravity CDU.

Output the flightdeck printer to a real printer, relay network traffic to a serial port, automatically save situations when certain activities occur or freeze the sim on each situation load - these are some of the options available through AdaptPSX.


SimSwitch Beta 1

SimSwitch is a Java application that acts as a software switch for the PSX network, similar to the Router (or the old Broker). SimSwitch can help prevent bad or erroring clients locking up PSX, hold client connections up should the main host go offline, and supports the unofficial addon protocol extension, allow applications to piggyback the PSX network for their own communcations. SimSwitch also incorporates a basic text Chat client, transmitting over the PSX network.
John Golin.
www.simulatorsolutions.com.au

Kurt

Just what I need to get my Aerosoft MCP up and running :)

Don't have time to test today but will dig in tomorrow.

Thank you for providing this software - greatly appreciated !
Best regards
Kurt

Pierre Theillere

Hello boys!

Great: the final AdaptPSX has made its first operational flight (LFPG - LFMN... even with a missed approach) in my setup, giving back life to my good old trusty MCP and MCDU that had been collecting dust for 5.5 years, wow!
Only thing is that I just noticed that my CMD R (hardware) button was no longer working (those things get old, after all) but it really changes Queenie's operating.
So, congrats and thanks John and Garry!
Pierre, LFPG

GerdD

Thanks to you for these AddOns.

On the Engravity CDU, in general the very last pixel line (bottom)
will be displayed as the very first pixel line on display.
Fond was F2. Is this something we have to live with or
can the whole display just moved up one pixel line?

Thanks again.
Gerd

bublegom

Hello

Thank you John for this very usefull addon
Just a little problem. You can not activate the right cdu with the aerosoft mcp hardware. With the mouse it works.
Tank again i am happy to reuse my old hardware.

Fran├žois

Frans Spruit

Hi John, Garry,

Thank you very much for the two programs, CDU working perfect, tomorrow the MCP  :D

Kind regards,

Frans Spruit EHAM

John Golin

No R Autopilot? Whoops - how did that get through! Sorry !

I'll hold off before releasing an update to catch a few more of the inevitable bugs :)
John Golin.
www.simulatorsolutions.com.au

bublegom

You don t have to be sorry. You did a wonderfull job. To reproduce the problem is simple. Load a situation like starting polar navigation mode.situ. When you disengage the auto-pilot and reactivate it, you can only with the mcp hardware engage the left or center auto-pilot
Hope this help

David Palmer

Remember... it's a beta release too.
Regards,
David.
a.k.a. 'The Commodore'

Pierre Theillere

#9
Hi John, bublegom and GerD!

Yesterday was intensive testing with LFPG - LFMN - TFFR:
- So, that's good news: my hardware MCP "CMD R" pushbutton isn't dead! (sorry for not using A/P R during early testing)
- I confirm the last pixel line appearing at first line of pixels on CDU screen to. (as if whole CDU display was shifted a pixel-line too much down)
- To be confirmed: hitting CLR key deletes last character (as expected) but then (at CLR key release and a CDU screen blanking) the whole scratchpad is deleted.
Apart that, fully stable, during more that 12 hours: well done!
Pierre, LFPG

John Golin

#10
I'm not sure about the 1 pixel thing.  I don't do any config of the display and I am not sure if there is any.  I get the same thing.

The SDK doesn't talk about it any config... of anyone has any additional information on the Engravity config let me know!

No-one has commented on the fact the 'degree' symbol is missing... again the SDK says nothing and I have no options apart from the first 128 ASCII characters.... :)
John Golin.
www.simulatorsolutions.com.au

John Golin

#11
Oh! Forgot to mention in the quick blurb - SimSwitch can be configured to allow 'read only' connections - so people or apps connected to SimSwitch cannot influence the 'upstream' instance of PSX.

This will be useful during WorldFlight - look but don't touch! :)
John Golin.
www.simulatorsolutions.com.au

Phil Bunch

That raises an interesting question - will Matt's sim run PSX in WorldFlight this fall?  

His sim is so sophisticated that it must require completing *many* complex tasks to get everything working and debugged!

Will he still require (I think) something like a dozen PCs to operate his sim?  PSX seems to be able to operate a lot of stuff with just one or two PCs.
Best wishes,

Phil Bunch

Kurt

#13
Hi John.

BRILLIANT !

Got it up and running with Aerosoft MCP plus DUAL EFIS and one EICAS (yes I was looking into the future back then and ordered two EFIS panels  :mrgreen:  )

Works fine allthough there is some hickups now and then  ;)

Only real "problems" is that all buttons and rotaries work but the two MINS and BARO rotaries on the F/O side. The associated RST and TFC buttons do work though.

In the manual it states that pushing the MINS button it should cycle between DH, MDA and BLANK but it does'nt seem to work (i can see in PSX that the button is pressed)

I have tried to swap the two EFIS panels to see if it is a hardware error (F/O EFIS has'nt been used ever before) but the result is the same.

Btw is it possible to adapt your software so the user can select what zoomrange is skipped?

Hope it is possible to fix :) - let me know if I can be of some help

Edited with more observations

Thank you in advance
Best regards
Kurt

Frans Spruit

Hello,

Wat cable should I use on the Aerosoft MCP.
I can't get usb to work, no connection @#$%
I have no RS232 port on my computers.
I know i am doing something wrong. :mrgreen:

Frans Spruit EHAM

Pierre Theillere

Hi Frans!

AdaptPSx is only able to handle serial inputs/outputs, and not USB. So, you need to purchase a USB - Serial converter. It even works fine on Linux!
Pierre, LFPG

Frans Spruit

Hi Pierre,

Thank you for the quick response. Going shopping tomorrow :D .
Hope you are well, and see you in Lelystad??

Kind regards

Frans

bublegom

no you don t need any hardware. The mcp pilot will convert the usb connection to a virtual com port. For me it is the com port 3. You select it in adaptPSX and all works fine.

brian747

#18
Ah, thank you.    :D

I have been struggling all day to get my MCP working using a Serial to USB hardware connection (it's as though the baud rate is too high or something - it partially works but then stutters). The AdaptPSX option to change the baud rate was greyed out. (The hardware driver had installed itself as COM3, incidentally).

When I tried a USB connection the Aerosoft747 MCP was detected by Windoze 7, but I couldn't get the driver to load at all (i.e. the one from C:\\Aerosoft\\USB). So how do I get the USB connection working?

(The MCP checks out fine with the Aerosoft diagnostic software).

Final question - what's the "MCP Pilot", by the way?

Many thanks,

Brian
(Author of "The Big Tutorial" for PS1, and "Getting started with PSX" Parts 1, 2, and 3).

bublegom

On the serial & gps tab in adaptpsx i have selected enable serial output and send hardware state. the com 3 is also selected with a speed of 38400 in grey.

Fran├žois