Old 744 Forum

Archived posts

Printing issue with AdaptPSX Beta 2.6

Page: 1

Author Post
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
Hello,

I have a strange issue with the printing function of AdaptPSX 2.6. The printer works fine with, for example, a wordpad file, and is printing the document without any problem. When I try to print something from AdpatPSX like ACARS ATIS, 0001 reports, etc, the printer driver "wakes up" because I can see the printer icon coming up on the windows task bar, but nothing happens physically on the printer. After some seconds, the printer icon disappears.

I configured AdaptPSX with "Printer output" selected, and my printer well appears in the menu, so I selected it. The text sent to the printer appears also in the control window of AdaptPSX. I really do not understand what's wrong. Please note this is my first use of AdaptPSX, so never tested with previous versions. I use Windows Vista 32bits and PSX server is on the same machine than AdaptPSX. Any help would be appreciated.
_______________
Jean-philippe
« Last edit by JP744 on Mon, 17 Nov 2014 21:11:43 +0000. »
Member
Registered: May 2009
Posts: 175
Location: NZAA
John, I have exactly the same problem with my Brother DCP-385C printer.
I am pleased JP744 brought this up as I assumed I had stuffed up somehow.

Cheers

Derek
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
Hi Derek. Nice to see I am not alone :D. My printer is a Samsung CLP315.
_______________
Jean-philippe
Member
Registered: May 2009
Posts: 772
Location: Sydney, Australia
Hmm - strange - thanks guys - will see if I can discover what is going on...
_______________
Member
Registered: May 2009
Posts: 241
Hi JP744 and Derek,

Not sure it will solve your issue, but with AdaptPSX v2.6 comes the possiblity to add some empty lines after the printout, including some "line feeds". (intended for "cash-ticket' printers with continuous paper rolls)
By chance, setting it to "non-zero" (e.g. 1 or 2) might "force" the printer to... print something, due to line-feed(s)? Just thinking about it... in case it may help!
_______________
Pierre, LFPG
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
Merci Pierre. Unfortunately I tried this option already without any success.
_______________
Jean-philippe
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
Hello,

Today I tried with another computer and 2 different printers. Still the same problem. Here is the debug log, if it can help somebody to understand :

Scanning for ports:
Scanning for ports:
-- listing properties --
java.runtime.name=Java(TM) SE Runtime Environment
sun.boot.library.path=C:\Program Files (x86)\Java\jre7\bin
java.vm.version=24.71-b01
java.vm.vendor=Oracle Corporation
java.vendor.url=http://java.oracle.com/
path.separator=;
java.vm.name=Java HotSpot(TM) Client VM
file.encoding.pkg=sun.io
user.script=
user.country=FR
sun.java.launcher=SUN_STANDARD
sun.os.patch.level=Service Pack 1
java.vm.specification.name=Java Virtual Machine Specification
user.dir=C:\Users\Jean-philippe\Downloads\Adap...
java.runtime.version=1.7.0_71-b14
java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
java.endorsed.dirs=C:\Program Files (x86)\Java\jre7\lib\...
os.arch=x86
java.io.tmpdir=C:\Users\JEAN-P~1\AppData\Local\Temp\
line.separator=

java.vm.specification.vendor=Oracle Corporation
user.variant=
os.name=Windows 7
sun.jnu.encoding=Cp1252
java.library.path=C:\Program Files (x86)\Java\jre7\bin;...
sun.awt.enableExtraMouseButtons=true
java.specification.name=Java Platform API Specification
java.class.version=51.0
sun.management.compiler=HotSpot Client Compiler
os.version=6.1
user.home=C:\Users\Jean-philippe
user.timezone=
java.awt.printerjob=sun.awt.windows.WPrinterJob
file.encoding=Cp1252
java.specification.version=1.7
user.name=Jean-philippe
java.class.path=C:\Users\Jean-philippe\Downloads\Adap...
java.vm.specification.version=1.7
sun.arch.data.model=32
java.home=C:\Program Files (x86)\Java\jre7
sun.java.command=C:\Users\Jean-philippe\Downloads\Adap...
java.specification.vendor=Oracle Corporation
user.language=fr
awt.toolkit=sun.awt.windows.WToolkit
java.vm.info=mixed mode, sharing
java.version=1.7.0_71
java.ext.dirs=C:\Program Files (x86)\Java\jre7\lib\...
sun.boot.class.path=C:\Program Files (x86)\Java\jre7\lib\...
java.vendor=Oracle Corporation
file.separator=\
java.vendor.url.bug=http://bugreport.sun.com/bugreport/
sun.cpu.endian=little
sun.io.unicode.encoding=UnicodeLittle
sun.desktop=windows
sun.cpu.isalist=pentium_pro+mmx pentium_pro pentium+m...
-- end list properties --
Connecting...
CONNECTED
CLIENT ID: 1
ACARS OOOI STATUS

FLIGHT NO DEPT/DEST
LY47 LLBG/VHHH
OUT
0239Z <=
OFF
****Z
ON FLIGHT TIME
****Z **:**
IN BLOCK TIME
****Z **:**

12:11:55 - 15 APR 2014



Once again, the printer driver gets busy (icon in the taskbar) but nothing happens physically.
_______________
Jean-philippe
Moderator
Registered: May 2009
Posts: 2449
Location: KTMB
Printer spooler in the way? Is the printer connection CLOSED after printing so that the driver releases the print file to the spooler? Do you need to add a Windows ^Z to the file to print maybe?
Member
Registered: May 2009
Posts: 241
Hi Hoppie,

Maybe you're right; even if my printer works fine with AdaptPSx, it doesn't cut the paper (after ending the printing), as it does when printing a "normal" file. The "paper cut" might be toggled by your closing stuff?
_______________
Pierre, LFPG
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
Jeroen Hoppenbrouwers wrote
Printer spooler in the way? Is the printer connection CLOSED after printing so that the driver releases the print file to the spooler? Do you need to add a Windows ^Z to the file to print maybe?


Hi Hoppie,

Thank you for your help. Yes the printer icon is shown and disappears from the task bar after about 30 seconds. Could you please develop your idea ? I do not understand what you mean by "Windows ^Z".
_______________
Jean-philippe
Moderator
Registered: May 2009
Posts: 2449
Location: KTMB
This all needs to be done by the programmer who drives the printer, in this case the AdaptPSX guru. Windows Printing is black magicks.
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
Jeroen Hoppenbrouwers wrote
This all needs to be done by the programmer who drives the printer, in this case the AdaptPSX guru. Windows Printing is black magicks.


Thanks a lot Hoppie. I hope John will read the thread and feedback.
_______________
Jean-philippe
Moderator
Registered: May 2009
Posts: 2449
Location: KTMB
I bet it is this common computer science problem: :mrgreen:

User posted image
Member
Registered: May 2009
Posts: 772
Location: Sydney, Australia
Hi;

I finally got around to looking at this - I have an idea, and will make a test version available soon to see if it resolves the issue... and no puppies were harmed in the making of AdaptPSX!
_______________
Member
Registered: Jan 2014
Posts: 299
Location: France (LFQQ)
John Golin wrote
Hi;

I finally got around to looking at this - I have an idea, and will make a test version available soon to see if it resolves the issue... and no puppies were harmed in the making of AdaptPSX!


Very good to listen about a printing improvement. Thank you very much John.
_______________
Jean-philippe
Member
Registered: Nov 2010
Posts: 139
Location: Vienna
Hi,

any news? Just confusion here ... downloading 2.6 beta, but version says 2.7 !?

Nevertheless, no printing possible ... WIN 7 64 bit, Canon PIXMA ip5200 USB

BR
Hans
_______________
Hans G. Schuetz
http://B747-400.net
Member
Registered: May 2009
Posts: 175
Location: NZAA
Hi John,

In a separate thread I wrote of problems with Adapt.

As is usual I tend to stuff things up but on this occasion everything works fine.

As I have installed a thermal printer (which works particularly well ) may I ask you Hardy if
a opportunity be given in preferences to cancel the screen print.

I assume this may also be beneficial for those with full rigs.


Cheers,

Derek
Moderator
Registered: May 2009
Posts: 5140
Hi Derek,

just go to Instructor > Preferences > Basics and ...

Deselect the checkbox "Allow paper sheet simulation".

(See lower right, under "Miscellaneous").


Cheers,

|-|ardy
Member
Registered: May 2009
Posts: 175
Location: NZAA
Thank you Hardy. I never thought to read the instructions :roll:

Derek
Member
Registered: Nov 2010
Posts: 139
Location: Vienna
Hi Derek,

hmm, have not found the thread .. but obviously working for you right now.

I just tried that with a "normal" printer - no chance - no output. I'm thiniking about buying a Brightek WH-E19 printer, but first I need to see the tool is working.


Seems I have to wait for the author to release a stable version!

BR Hans
_______________
Hans G. Schuetz
http://B747-400.net
Member
Registered: May 2010
Posts: 99
Location: Brussels
Any news about this guys?
Same problem here with an HP printer all in One on Windows 8.1
Working fine in windows but in AdaptPSX only the print icon appears in the task bar but the printer does not do anything further...

Thanks!

Regards,
Sylvain

Page: 1

Old 744 Forum is powered by UseBB 1 Forum Software