Old 744 Forum

Archived posts

ViualPSX Suite upgrade to v 6.1 nd 7.1 released

Page: < 1 2 3 >

Author Post
Member
Registered: Dec 2011
Posts: 497
Location: Portugal
CarlBB wrote
Hi,

I did not download 6.0 - instead I came to the party with 6.1 (just mentioning in case relevant).

When I ran makerunways I chose, FSX:SE and it created a 62 file. However, Visual PSX will not run with this. It says I need 61 file. I was able to make the 61 file by choosing the option FSX (not SE). Is that what I should have done?

Thanks

Carl


Yes, this is the correct choice if you do not have a hybrid FSX install ( boxed + SE ), because, as Garry pointed out, FSX:SE "spoofs" the FSX reg. entries
_______________
Jose Monteiro
Member
Registered: Nov 2010
Posts: 139
Location: Vienna
CarlBB wrote
I did not download 6.0 - instead I came to the party with 6.1 (just mentioning in case relevant).


Hi,

I downloaded build 5625 (6.1) as well, but RunwaysPSX is 6.0 build 5609 in that package.

BR Hans

PS: downloaded twice, should not be a corrupt file ...
_______________
Hans G. Schuetz
http://B747-400.net
Member
Registered: Jul 2014
Posts: 50
Location: Basel, CH
That is the version of RunwaysPSX I have been using as well.
Don't know if it's of any relevance but it's the only version I've been able to find.

Regards
Simon
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi all,

I found a bug in RunwaysPSX that was interfering with version 6 functions and fixed it. I also revised the handling of FSX-SE and it should now be processed correctly.

Because of the way Steam installs itself you may need to run RunwaysPSX as an administrator. Do this if FSX-SE does not appear in the list, but you know it should.

Build 5631 is now available for download.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: Nov 2010
Posts: 139
Location: Vienna
Hi Garry,

thanks for the Update!

This build offers FSX only, but still exiting after a few seconds without any message :(
I checked the "Run as administrator" box, just as an info. X-Checked my system again with Version 5 in same folder .. works.

Anything I can do to help you tracking the error down?

BR Hans
_______________
Hans G. Schuetz
http://B747-400.net
Member
Registered: Feb 2011
Posts: 190
Location: 2nm from rwy 06 EGLF
Many thanks indeed for the update, Garry! :D

Cheers,

Brian
_______________
(Author of "The Big Tutorial" for PS1, and "Getting started with PSX" Parts 1 and 2).
Member
Registered: Nov 2011
Posts: 77
Hi, I just downloaded .5631 from the site and isntalled it. When I try and run ViuslaPSX from the 71 folder, it redirects me to an updated version of the exe, which is supposed to be in the 5631 build, which is exactly the one I installed .....

Andrea
Member
Registered: Nov 2011
Posts: 77
Just an idea: would any1 send me their runways file (P3D2 version, so 7.1) so that I can try and run this version of VisualPSX?

Tnx

Andrea
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi everyone,

I have just recompiled everything to build 5632, now available for download.

This stops VisualPSX from repeatedly informing you that an update is available. I didn't recompile VisualPSX for build 5631 because there was no change to it, but I forgot that VisualPSX is the app that checks for updates.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: May 2009
Posts: 418
Location: Australia
B747-400 wrote
Anything I can do to help you tracking the error down?

Hi Hans,

Yes thanks, but I will have to write out detailed instructions first. I will do that later today if I have time. It will involve registry and folder searches.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: Nov 2010
Posts: 139
Location: Vienna
Great, Garry!

I'm ready when you are 8)

BR Hans
_______________
Hans G. Schuetz
http://B747-400.net
Member
Registered: Nov 2011
Posts: 77
Thank'you for the new version; unfortunately, I still have the same issue: as soon as I run RunwaysPSX.exe from 7.1 folder it exits without an error; this prevents me to build the runways database, so no VisualPSX.

As I wrote yesterday, maybe someone can post their runways file (P3D2 versin) so I can try and finally run VidualPSX?

Tnx

Andrea
Member
Registered: Jan 2012
Posts: 72
Location: Germany (near EDCB)
To test out my Runway file, For those who use the FSX and Runway PSX can not start:

https://www.dropbox.com/s/nxkmlfmqmpmh2ki/Runways_PSX_v61.vpx?dl=0

Created with the latest version for FSX. Without additional airports, only FSX default Airports. Copy this file to the Visual PSX folder. So you can test the program at least once.

Maybe someone uploaded a file for FSX:SE and P3D. ;)
_______________
...Peter :)
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi all,

I found a difference in the way FSX-SE creates registry data. Build 5634 is now available and hopefully will work properly. In this build you don't need to run RunwaysPSX as an administrator.

Good luck!
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: May 2009
Posts: 418
Location: Australia
simbro wrote
Edit:
Garry, where is the scenery info being read from exactly?
I've reduced the scenery.cfg file in C:\ProgramData\Microsoft\FSX to one area entry only...

Hi Simon,

Sorry to have overlooked your query. The scenery.cfg file in c:\ProgramData... is the reference copy used by FSX to restore the scenery settings to default values. It is not meant to be altered.

The working copy for your Windows version is in C:\Users\{your user name}\AppData\Roaming in the software vendor's folder. (For FSX that would be the Microsoft folder.)

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: Jul 2014
Posts: 50
Location: Basel, CH
Hi Garry,

That can't be right.

I've just had a look inside the folder you mention and found an original scenery.cfg file dated 12.09.2006 containing just the default scenery paths! This file cannot be the active file because in this case I wouldn't be seeing any addon scenery whatsoever that is installed outside of 'FSX\Addon Scenery'... I think this is the reference file you mention and the one in ProgramData is the working copy. The roaming profile path does contain various other working files such as fsx.cfg, xml.cfg, dll.cfg, etc. but not the working scenery.cfg

For years, I've been modifying the scenery.cfg file in C:\ProgramData\Microsoft\FSX both manually and using a scenery tool and these changes have always been reflected in FSX after a restart.

In fact, I didn't even realise that there was a scenery.cfg file in the roaming profile path and had always assumed that the file in FSX root was the 'backup'... (if this 'FSX-root' file is deleted then FSX goes haywire and suggests a re-install!)

Regards
Simon
« Last edit by simbro on Fri, 05 Jun 2015 20:34:28 +0000. »
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi Simon,

Thanks for alerting me to this situation.

My copies of FSX, P3Dv1 and FSX-SE are all on my old XP computers and store the active scenery.cfg file where I indicated. In my code I use the appdata environment variable to find its location for each sim.

My copy of P3Dv2 is on a Win 8.1 computer and stores its active scenery.cfg file under C:\ProgramData. I use the programdata environment variable to find its location.

I thought the latter location was unique to P3Dv2 but it now appears from your post that the location for all the sims depends on the Windows version. I shall include this condition in the next update.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi all,

Build 5635 is now available. RunwaysPSX should now work correctly with Win7 and Win8. Thanks to Simon for revealing the error.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: Aug 2014
Posts: 375
Location: Camberley, UK
Garry,

I am using 7.1 with P3D 2.5 and am still getting "stutters".
They manifest themselves as "mini-freezes" of maybe 1/2 second or so with significant bank and pitch changes - then the picture "jerks" to the new position.
Also the forward movement is smooth for most of the time, but will similarly just stop for a fraction of a second.

I have used identical scenery, aircraft and P3D loading using a WIDEVIEW client and server from another networked PC with P3D - and the result is smooth, so I don't understand why VisualPSX is having a different result. (The P3D frame rates are always high - well in excess of 100)

I know that XVIEW has the interpolation element incorporated - is this a feature of VisualPSX, and can it be turned off?

Peter
Member
Registered: Nov 2011
Posts: 77
Garry Richards wrote
Hi all,

Build 5635 is now available. RunwaysPSX should now work correctly with Win7 and Win8. Thanks to Simon for revealing the error.

Cheers,



Sorry, still the same problem: it starts, but when I push "start processing" it just vanishes.

Andrea
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi Peter,

If you are running WidevieW with VisualPSX they may be interfering with each other. Both are sending attitude and position data, although they use different ports. VisualPSX doesn't use extrapolation so that's not a possible cause.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: May 2009
Posts: 418
Location: Australia
Hi Andrea,

Could you tell me how much, if any, of this sequence happens when you press the "start processing" button?

1 The button text changes to "stop processing".

2 A message appears in the lower frame stating "extracting P3Dv2 addon airport and runway data...".

3 If you have any addon airports the file names and counters start changing in the upper frame, otherwise there is a slight delay while the scenery library catalogue is searched.

4 The message in the lower frame is replaced by "extracting P3Dv2 standard airport and runway data...".

Thanks,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: Nov 2011
Posts: 77
Thank'you Garry, all I see is some string flash near "file" and something under "status", but it's really too fast to be read. Then it's over. The whole thing lasts maybe one tenth of a second. The first time I run it it lasts a bit longer, maybe half a second, then, when files are cached, it's virtually instantaneous.

Bye

Andrea
Member
Registered: May 2009
Posts: 418
Location: Australia
Excellent, Andrea! That is useful info telling me where to look and I have now been able to introduce an error that causes an instant crash. At this stage it could be due to a corrupt airport file but treat that as a differential diagnosis. I have to put more thought into likely causes.

Cheers,
_______________
Garry

Website: flightsim.garryric.com
Member
Registered: Nov 2010
Posts: 139
Location: Vienna
Hi Garry,

just to let you know: the latest build works for me!
Thans a lot!

BR Hans
_______________
Hans G. Schuetz
http://B747-400.net

Page: < 1 2 3 >

Old 744 Forum is powered by UseBB 1 Forum Software