Welcome, Guest. Please login or register.
Did you miss your activation email?

News: Precision Simulator update 10.94 (14 January 2020) is now available

Author Topic: Firefox browser  (Read 318 times)

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 11002
    • Aerowinx
Firefox browser
« on: Wed, 4 Dec 2019 20:30 »
Hello,

since version 71.0, and shortly before already, my Mac OSX Firefox "text blocks" don't have shadows anymore. I mean these kind of blocks:

• Tooltips

• Menus that pop up by right mouse clicks

• Menus that extend down from the menu bar by left mouse clicks

It seems that all GUI objects are now shadowfree except for the Firefox main menu at the top of the OSX desktop.

I have searched the net but found no related hints. The keyword "shadow" may be too unsharp.

Not a big problem. But when you look at a web site that has a white background, it's not quite clear what part of the text belongs to the menu text. The white menu box isn't even outlined.

Does anybody know any trick to get those standard shadows back?


Regards,

|-|ardy

martin

  • Join date: May 2009
  • Location: EFTO
  • Posts: 599
Re: Firefox browser
« Reply #1 on: Wed, 4 Dec 2019 21:10 »
 
Quote from: Hardy
all GUI objects are now shadowfree
That at least sounds suspiciously like the now global trend of most everyone to look like Windows 10, which means flat (and to also splash around oodles of (on desktop machines) useless whitespace for the benefit of the mobile Wurstfinger (Fat Fingers) brigade...)

Firefox has perpetrated a similar* major "modernisation" of their UI ("Australis"), which at the time triggered a lot of complaints; but that was over five years ago, and not all the symptoms fit which you describe.
So, this is just a rant idea...

Cheers,
Martin

* possibly trying to look like Chrome (rather than like Win10)

United744

  • Join date: Oct 2014
  • Posts: 805
Re: Firefox browser
« Reply #2 on: Wed, 11 Dec 2019 21:32 »
Too many UIs are inflicted by bad design these days.

The one that really ANNOYS the hell out of me is an existing app dev taking a good, solid, working UI and butchering it for who knows what reason, often losing functionality, and making it a PITA to use.

These UI designers need to be told where to go.

Jeroen Hoppenbrouwers

  • Moderator
  • Join date: May 2009
  • Location: KTMB
  • Posts: 3681
  • Hoppie designs avionics equipment for airliners.
    • http://www.hoppie.nl/
Re: Firefox browser
« Reply #3 on: Wed, 11 Dec 2019 23:23 »
Actually, lots of good stuff is butchered by the desire to make it better. Eternal tinkering, adding features, adding more features, until the once good thing is so overloaded that it can only fall over and crash.

Knowing when to stop developing something, and just keeping it alive (security patches, adjusting to new operating system kinks, etc.) is something few developers dare. Apparently there is no "challenge" in this kind of maintenance. Only if the thing happens to be just a tool and the developer uses it as that tool, you have a chance.

Until somebody has an itch and forks it.

Or somebody wants to buy market share and merges the thing with something else to "innovate." Brrrrrr.


Hoppie

mgeiss

  • Join date: Jan 2017
  • Location: EDDS/110/15
  • Posts: 91
Re: Firefox browser
« Reply #4 on: Thu, 12 Dec 2019 03:50 »
It's not a general issue with FF 71 on the mac, because I get shadows on all the objects you mentioned.

That being said, I'm on an older OSX version (10.11.6 El Capitan) and I don't use many addons within FF, only NoScript.
Cheers,
Matthias

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 11002
    • Aerowinx
Re: Firefox browser
« Reply #5 on: Thu, 12 Dec 2019 05:08 »
I'm on OSX version 10.9.5 -- even older --, and my only relevant Firefox add-on is a mouse gestures add-on.

Glad to conclude that there must be a way to get the shadows back.

Ton van Bochove

  • Join date: Jun 2009
  • Location: EHAM/EHBK
  • Posts: 87
Re: Firefox browser
« Reply #6 on: Thu, 12 Dec 2019 06:32 »
I have OSX Catalina and I have the shadows in FF too. Can you open Safari or another browser to see if you have shadows than you can see if it is an OSX or FF issue

Ton
Ton

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 11002
    • Aerowinx
Re: Firefox browser
« Reply #7 on: Thu, 12 Dec 2019 07:58 »
Sure, just my Firefox v71+ has this problem:



Maybe there's a hidden switch for graphics acceleration or something in Firefox which might disable the shadows.

The checkbox under "Performance" and restarting Firefox makes no difference.
« Last edit: Thu, 12 Dec 2019 08:47 by Hardy Heinlin »

mgeiss

  • Join date: Jan 2017
  • Location: EDDS/110/15
  • Posts: 91
Re: Firefox browser
« Reply #8 on: Thu, 12 Dec 2019 09:25 »
Very strange, indeed.

It could be a userchrome.css which can be used to customize the UI (and disable shadows), but unless you use a custom css (and maybe forgot about it), I'm out of ideas.

Could you check the value (true/false) of toolkit.legacyUserProfileCustomizations.stylesheets in about:config? If it's set to true, try switching it to false and restart FF.
Cheers,
Matthias

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 11002
    • Aerowinx
Re: Firefox browser
« Reply #9 on: Thu, 12 Dec 2019 09:38 »
Thank you.

If I understand it correctly, the userChrome.css was introduced with FF 57. In that version I still got shadows. I didn't edit it (I don't even know how to edit it).

I just tested the toolkit.legacyUserProfileCustomizations.stylesheets. It was set to false. Setting it to true and restarting didn't bring the shadows back. Now it's reset to false. Still no change.

Ton van Bochove

  • Join date: Jun 2009
  • Location: EHAM/EHBK
  • Posts: 87
Re: Firefox browser
« Reply #10 on: Thu, 12 Dec 2019 09:45 »
Ton

Hardy Heinlin

  • Moderator
  • Join date: May 2009
  • Posts: 11002
    • Aerowinx
Re: Firefox browser
« Reply #11 on: Thu, 12 Dec 2019 10:04 »
Thanks, Ton. Nope, that trick doesn't work either ...

I guess it's a rare bug that just occurs in my software constellation.